侧边栏壁纸
博主头像
DevWiki博主等级

不怕慢,只怕站!

  • 累计撰写 156 篇文章
  • 累计创建 90 个标签
  • 累计收到 0 条评论

目 录CONTENT

文章目录

Android plugin is not compatible with Gradle

DevWiki
2016-08-31 / 0 评论 / 0 点赞 / 0 阅读 / 3175 字 / 正在检测是否收录...
温馨提示:
本文最后更新于 2024-03-31,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。
updated: 2018/05/24 09:05:37
status: publish
author: DevWiki
categories: 
  - 工具
tags: 
  - gradle
  - gradle plugin
thumb: 
thumbStyle: default

今天在更新Android Studio至2.2Beta3,打开项目突出出现了异常:

Error:Android plugin 2.1.0 is not compatible with Gradle 2.14.1.
Fix plugin version and sync project

Open Documentation

打开上面提示的界面,看到如下信息:

Android Gradle Plugin Requires Gradle

由上图可以看出,不同的Android Gradle Plugin版本仅支持对应的Gradle版本.

2.1.0的Gradle Plugin仅支持Gradle 2.10 - 2.13,而我使用的是2.14.1所以报错啦.

以下为修复步骤:

  1. 修改确认Project build文件的Gradle Plugin版本
    请输入图片描述
  2. 确认Setting中的Gradle配置
    请输入图片描述
  3. 确认Project Gradle版本配置
    请输入图片描述
    上图红框出版本应改为2.10 ~ 2.13
  4. 重新build一下项目,问题解决.

更新

新的兼容列表如下:

Plugin version Required Gradle version
1.0.0 - 1.1.3 2.2.1 - 2.3
1.2.0 - 1.3.1 2.2.1 - 2.9
1.5.0 2.2.1 - 2.13
2.0.0 - 2.1.2 2.10 - 2.13
2.1.3 - 2.2.3 2.14.1+
2.3.0+ 3.3+
3.0.0+ 4.1+
3.1.0+ 4.4+

网址参见此处:Android Plugin for Gradle Release Notes  |  Android Developers

0
  1. 支付宝打赏

    qrcode alipay
  2. 微信打赏

    qrcode weixin

评论区